Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - GPEA040: Error : 2601 No se puede insertar una fila de clave duplicada en el objeto 'dbo.RCN010'


Ocurrencia
En modulo de Gestión de Personal, al ingresar a la rutina de Conceptos (GPEA040) se genera un error por duplicidad.

DB error (Insert): -37 File: RCN010 - Error : 2601 (23000) (RC=-1) - [Microsoft][ODBC SQL Server Driver][SQL Server]No se puede insertar una fila de clave duplicada en el objeto 'dbo.RCN010' con índice único 'RCN010_UNQ'. El valor de la clave duplicada es ( , 0006, 0). ( From tISAMFile::Write )
Thread ID [5488] User [Administrador] IO [601] Tables [22] MaxTables [22] Comment [GPEA040 - TCPIP - ThreadID(6080)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/MP12VAL_BAKELS] DBThread [(SPID 172)] Started [10/01/2019 16:40:59] IP [127.0.0.1:3333] IDLE [ ] InTransact [ ] Memory [592808] Running [ROP_WRITE] RCV [21959] SND [33350] TCBuild [20171117-20180109]
INSERT INTO dbo.RCN010(RCN_FILIAL,RCN_CODIGO,RCN_DESCRI,RCN_OBRIGA,RCN_HELP,RCN_VERSAO,R_E_C_N_O_) VALUES ( ?,?,?,?,?,?,?)


Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - Versión 12117


Causa
Este incidente ocurre por la duplicidad en los registros de la tabla RCN o bien por algún cambio realizado en la estructura del diccionario de datos para las tablas SRV o RCN.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Garantice tener el estándar del diccionario de datos en la tabla SX2, SIX y SX3 para las tabla SRV y RCN, se anexa la imagen;

Nota: En caso de tener información diferente en las tabla SIX, SX2 y/o SX3, se sugiere descargar el diccionario de datos completo y diferencial para su país y versión de ambiente que tiene del portal del Cliente; En ambiente de pruebas, aplicar el diccionario de datos descargado en la carpeta systemload, después aplicar el compatibilizador UPDDISTR.

a1.jpg

a2.jpg

* Al final del articulo se anexa un ejemplo de las tablas de un ambiente de pruebas estándar de Soporte con sigamat.emp a dos dígitos.



2. Garantice no tener registros duplicados en la tabla RCN, con base al identificador único de la tabla (X2_UNICO), Se anexa imagen del contenido de la tabla RCN;

a4.jpg

 - En caso de tener registros duplicados, deberá borrarlos desde la consulta de la tabla RCN vía APSDU, una vez deletados, aplique un PACK a la tabla RCN para borrar físicamente  los registos duplicados que deleto previamente.

* Al final del articulo se anexa el contenido de la tabla RCN de un ambiente de pruebas estándar de Soporte con sigamat.emp a dos dígitos, donde no existen registros duplicados en la tabla RCN.


3. Garantizados los Puntos anteriores, valide el escenario reportado, ingrese a la rutina de Conceptos (GPEA040), valide que no sea presente el error.log de duplicidad.


- Archivo con SIX, SX2 y SX3 de las tablas RCN y SRV, adicional al contenido de la tabla RCN sin registros duplicados.


¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _