Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Reloj registrador electrónico (SIGAPON) - Modelo II - PONM030: No se generan marcaciones cuando la tabla SRA esta compartida por filial.



Ocurrencia
En modulo de Reloj Registrado Electrónico (SIGAPON), la rutina de generación de marcaciones (PONM030) no esta generando registro de las marcaciones acorde a la configuración de mi turno y regla de apunte, cuando la tabla de empleados (SRA) esta compartida por filial (X2_MODO = C).


Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Reloj registrador electrónico (SIGAPON) - Modelo II - Versión 12


Causa
Este incidente ocurre por haber cambiado manualmente desde el modulo configurador o bien por APSDU el modo de acceso a compartido por filial (X2_MODO) de la tabla de empleado SRA .


Solución
Para solucionar esta ocurrencia, considere los siguientes pasos:

1. El Squad de Desenvolvimento RH - Gestão do Capital Humano padrón nos indica que los módulos de la suite de RH como son SIGAGPE, SIGAPON, etc, fueron estructurados partiendo del principio que todo funcionario debe pertenecer solamente a una sucursal, siendo que la tabla SRA de empleado siempre debe estar con compartimiento exclusivo;

2. Utilizar la tabla SRA de forma compartida provocara el funcionamiento incorrecto del sistema;

3. La rutina PONM030 utiliza el campo de filial para la identificación de los registros a ser procesados, donde inicialmente validar que exista el empleado (SRA), con base a esta información hace la validación hacia otras tablas como por ejemplo cambio de turno (SPF) donde verifica la filial, matriculo y turno;

p1.jpg


4. Por estándar del diccionario de datos esta tabla SRA esta en modo exclusiva;

p2.jpg


5. Es necesario que regrese el modo de compartición exclusiva de la tabla SRA al estándar del diccionario de datos, garantice que sus registros de empleados en la tabla SRA tengan asignado un código de filial y valide nuevamente el escenario reportado.



Conozca más:
Para consultar la información contenida en el banco de conocimientos, acceda a los siguientes enlaces:

Help On-Line: Genera Marcaciones (PONM040)

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _