Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBR295 - Saldos Vs Periodos: Error : 1909 El nombre de columna 'CLVL' aparece más de una vez

Ocurrencia

En modulo Contabilidad de Gestión, al intentar generar el informe Saldos Vs Periodos (CTBR295) se genera un error.log:

_SC00: Error : 1909 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]No se pueden usar nombres de columna duplicados en índice.

El nombre de columna 'CLVL' aparece más de una vez. ( From tISAMFile::CreateIndex )

Thread ID [2652] User [gpeytral] IO [9412] Tables [32] MaxTables [32] Comment [CTBR295 - TCPIP - ThreadID(4280)] Status []
SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/MigraGPC] DBThread [(SPID 58,70)] Started [13/12/2018 13:57:29]
LastIO [13/12/2018 13:58:44] IP [10.10.10.60:1236] RCV [267756] SND [901762] TCBuild [20170202-20171004]

CREATE INDEX SC001 ON dbo.##TMPSC00_58(CLVL+CUSTO+ITEM,CLVL,R_E_C_N_O_,D_E_L_E_T_) on FWTEMPORARYTABLE:CREATE(FWTEMPORARYTABLE.PRW) 23/10/2018 18:06:50 line : 116



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - Versión 12117



Causa
Este incidente ocurre por desactualización de la rutina CTBR295.



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:


1. Se sugiere tener la actualización de binarios y librerías disponibles en el portal del cliente, aplicados en su ambiente de pruebas inicialmente;

Downloads y atualizaciones de Librerias

Downloads y atualizaciones Binarios - APPSERVER

Downloads y atualizaciones Binarios - SMARTCLIENT

 


2. Verifique tener la rutina CTBR295 con fecha igual o superior al 22/08/2018 ; 

 Patch P12117_CTBR295_20180822_DSERCTR1-13948.ZIP


3. En caso de descargar los patchs, deberá aplicar en su ambiente con previo respaldo del RPO, eligiendo la opción aplicar solo fuentes actualizados;

 


4. Ingrese nuevamente a la rutina Saldos Vs. Periodos (CTBR295) valide el escenario reportado.



Conozca más:
Para consultar la información contenida en el Help On-Line, acceda a los siguientes enlaces:

Help On-Line: Saldos vs. Períodos

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _