Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - variable is not array - Type [U] on MAFISRET(MATXFIS.PRX)

Ocurrencia
En el módulo de Compras, al intentar analizar la cotización desde la rutina Analiza Cotización  es presentado el siguiente error log que impide llevar a cabo el análisis de la cotización correspondiente:
variable is not array - Type [U] on MAFISRET(MATXFIS.PRX)
Error.png


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - 12

Causa
El error log es presentado porque el análisis esta siendo realizado desde la rutina MATA160, sin embargo, como parte de la evolución tecnológica del sistema, a partir de la versión 12 de Protheus la rutina para llevar a cabo el proceso de 'Análisis de Cotizaciones' es la MATA161.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Desde el módulo configurador, SIGACFG, lleve a cabo el ajuste del menú para agregar la rutina correcta en el menú de Protheus: MATA161
2. Posteriormente ingrese al módulo de Compras -> Actualizaciones -> Solic/Cotizar -> rutina Analiza Cotización:
1.png

3. Seleccione la solicitud correspondiente y seleccione la opción Mapa de cotización:
2.jpg

4. Verifique los datos o realice los ajustes pertinentes y seleccione la opción Grabar:
3.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _