Ocurrencia
En el modulo Compras, en en el catálogo de Productos a través de la rutina MATA010, se detona error.log al intentar realizar el borrado de un producto.
"TNB010: SetOrder - Index not found. on MDTVALESB1(MDTUTIL.PRX)"
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – Versión 12.1.17
Causa
Este incidente se produce por inconsistencias en el diccionario de datos, comúnmente identificada cuando los archivos Sxs no se actualizan de forma correcta. Por lo tanto, antes de realizar algún cambio, es importante que se asegure de estar utilizando los archivos SXSARG.TXT y SDFARG.TXT actualizados con la última versión disponible en el portal del cliente.
Solución
1. Realice un respaldo del Diccionario de Datos de su ambiente.
2. Realice un respaldo de la Base de datos de su ambiente.
3. Verifique los indices de las tablas TNB y TNX, los cuales deben estar de la siguiente manera:
Indices Tabla TNB-Epi por FunciónIndices Tabla TNX-Epi vs Riesgos
4. En caso de identificar inconsistencias, realice los ajustes correspondientes.
5. En el archivo adjunto SIX_TNX_TNB.zip se proporciona el archivo de índices de cada tabla, para que si es el caso, realice la corrección vía apsdu.
6.- Confirme que el incidente se corrige.
0 Comentarios