Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - Error: TNB010: SetOrder - Index not found. on MDTVALESB1(MDTUTIL.PRX)

Ocurrencia
En el modulo Compras, en en el catálogo de Productos a través de la rutina MATA010, se detona error.log al intentar realizar el borrado de un producto.

"TNB010: SetOrder - Index not found. on MDTVALESB1(MDTUTIL.PRX)"


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – Versión 12.1.17

Causa 
Este incidente se produce por inconsistencias en el diccionario de datos, comúnmente identificada cuando los archivos Sxs no se actualizan de forma correcta. Por lo tanto, antes de realizar algún cambio, es importante que se asegure de estar utilizando los archivos SXSARG.TXT y SDFARG.TXT actualizados con la última versión disponible en el portal del cliente.

Solución
1. Realice un respaldo del Diccionario de Datos de su ambiente.
2. Realice un respaldo de la Base de datos de su ambiente.
3. Verifique los indices de las tablas TNB y TNX, los cuales deben estar de la siguiente manera:

Indices Tabla TNB-Epi por FunciónIndices_TNB.jpgIndices Tabla TNX-Epi vs RiesgosIndices_TNX.jpg

4. En caso de identificar inconsistencias, realice los ajustes correspondientes.
5. En el archivo adjunto SIX_TNX_TNB.zip se proporciona el archivo de índices de cada tabla, para que si es el caso, realice la corrección vía apsdu.
6.- Confirme que el incidente se corrige.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _