Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - invalid property ADEFALIGN on FWBRWMODELCONFIG:DESTROY(FWBRWMODELCONFIG.PRW) 31/08/2018 13:40:11 line : 115


Ocurrencia
Al ingresar a diferentes rutinas del modulo de Compras, es generado un error.log:

invalid property ADEFALIGN on FWBRWMODELCONFIG:DESTROY(FWBRWMODELCONFIG.PRW) 31/08/2018 13:40:11 line : 115



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12.1.17



Causa
Este incidente ocurre por diversas situaciones.



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

A) Garantice tener la actualización de binarios y librerías disponibles en el portal del cliente, aplicados en su ambiente de pruebas inicialmente;

Downloads y atualizaciones de Librerias

Downloads y atualizaciones Binarios - APPSERVER

Downloads y atualizaciones Binarios - SMARTCLIENT

B) Limpieza C-TREE

Para efectuar la limpieza de C-TREE, deberá realizar los siguientes pasos:

Deberá parar todo el ambiente de Protheus, servidores de Protheus (Servicio Maestro y esclavos en caso de tener Balanceo de Carga), WorkFlow y Jobs configurados;

  • Parar el servicio de Ctree Server;
  • Borrar los archivos de indices (*.CDX, .IDX e *.IND) de Protheus que esta en la carpeta SYSTEM de su ambiente;
  • Borrar el contenido de la carpeta CTREEINT, ubicada dentro del system del ambiente;
  • Borrar los archivos de indices (*.CDX) de Protheus que están en la carpeta PROFILE ubicada en la carpeta de PROTHEUS_DATA de su ambiente;
  • Borrar el contenido de la carpeta CTREEINT, ubicada dentro de la carpeta  PROFILE;
  • Ubique la carpeta donde esta instalado el CtreeServer, borre los archivos con extensión  *.FCS (Lo idea es crear una carpeta de respaldo y ahí colocar estos archivos);
  • Iniciar el servidor CtreeServer;
  • Iniciar por lo menos un servicio de Protheus en caso de existir Balanceo de Carga;
  • Realice el acceso STAND ALONE (un solo usuario) en Protheus, para que sean creados los indices, evitando la concurrencia y duplicidad;
  • En caso de que existan mas empresas, debe entrar a cada una de ellas para que sean creados los indices de cada una de las empresas;
    - Puede utilizar el modulo de Configurador  para que los indices sean creados al momento de consultar las tablas en la rutina diccionario de datos, siendo una opción que agiliza la creación de los indices;
  • Después de la creación de  todos los indices en cada empresa, salga del modulo del configurador;
  • Pare los servicios del CtreeServer y reinicie el servicio;
  • Levante los servicios de Protheus, valide el ingreso de los usuarios.

 

Conozca más:
Para consultar la información contenida en TDN, acceda a los siguientes enlaces:

TDN Limpieza C-TREE

 

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _