Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - Error log variable is not array - Type [N] on RETCUSENT(SIGACUSA.PRX)

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - Error log variable is not array - Type [N] on RETCUSENT(SIGACUSA.PRX)

Aparición 
Al ejecutar la rutina MATA330 en un entorno que tiene movimiento de salida por nota de devolución de compra, se genera el registro de errores. 

Ambiente 
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - A partir de la versión 12.1.17 

Causa 

Al ejecutar la rutina MATA330 en un entorno que tiene movimiento de salida por nota de devolución de compra, se genera el registro de errores.

MV_CUSFIL: F

Método de liquidación = mensual.

En este escenario al ejecutar la rutina MATA330 se genera el registro de errores como se indica a continuación.

THREAD ERROR ([1824], usuario.local, SPON4753)   19/10/2018 09:16:38

variable is not array - Type [N] on RETCUSENT(SIGACUSA.PRX) 10/10/2018 20:07:02 line : 4428

 [TOTVS build: 7.00.131227A-20180920 NG]

Called from RETCUSENT(SIGACUSA.PRX) 10/10/2018 20:07:02 line : 4428

Called from A330TTFIM(SIGACUSA.PRX) 10/10/2018 20:07:02 line : 11748

Called from A330RECALC(MATA330.PRX) 10/10/2018 16:46:04 line : 5896

Called from MA330PROCESS(MATA330.PRX) 10/10/2018 16:46:04 line : 1365

Called from {|lEnd|MA330Process(aListaFil,lBat,@lEnd,nRateioFrota,nRateioVeiculo,nRateioViagem,lExistProc)}(MATA330.PRX) 10/10/2018 16:46:04 line : 1365

Called from { || FWSetShowKeys( .F. ), Eval( bAction, @lEnd ),lEnd := .t. , FWSetShowKeys( .T. ), oDlgModal:Deactivate() }(MSPROCES.PRW) 17/10/2018 16:46:25 line : 1365

Called from {|Self|(Eval(oSelf:bInit))}(FWDIALOGMODAL.PRW) 17/10/2018 16:46:20 line : 1365

Called from ::MSDIALOG:ACTIVATE line : 1365

Called from FWDIALOGMODAL:ACTIVATE(FWDIALOGMODAL.PRW) 17/10/2018 16:46:20 line : 461

Called from PROCESSA(MSPROCES.PRW) 17/10/2018 16:46:25 line : 107

Called from {||  If(MTA330TOk(),(Processa({|lEnd|MA330Process(aListaFil,lBat,@lEnd,nRateioFrota,nRateioVeiculo,nRateioViagem,lExistProc)},OemToAnsi(FWI18NLang("MATA330","STR0007",7)),OemToAnsi(FWI18NLang("MATA330","STR0011",11)), .F. ),oDlg:End()),)}(MATA330.PRX) 10/10/2018 16:46:04 line : 107

Called from ::MSDIALOG:ACTIVATE line : 107

Called from MATA330(MATA330.PRX) 10/10/2018 16:46:04 line : 379

Called from __EXECUTE(APLIB090.PRW) 17/10/2018 16:46:22 line : 636

Called from MDIEXECUTE(APLIB260.PRW) 17/10/2018 16:46:22 line : 836

Called from STATICCALL(APLIB260.PRW) 17/10/2018 16:46:22 line : 836

Solución

Para la corrección del error aplique el paquete disponible o superior. A continuación le compartimos el paquete con fecha del 19/10/2018. Aplicar y validar después de un previo respaldo. 

https://centraldeatendimento.totvs.com/hc/pt-br/article_attachments/360014206351/PACOTE_2643481_DMANMAT01-14409_12.1.17.ZIP

 

 

 

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _