Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Activo FIjo (SIGAATF) - ATFA060: type mismatch on compare on AF060DATA(ATFA060.PRX) 16/07/2018 10:26:02 line : 1308


Ocurrencia
En modulo de Activo Fijo, al intentar generar una transferencia de sucursales a través de la rutina ATFA060, es generado el error:


type mismatch on compare  on AF060DATA(ATFA060.PRX) 16/07/2018 10:26:02 line : 1308



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Activo FIjo (SIGAATF) - Versión 12.1.17



Causa
Este incidente ocurre por la incorrecta configuración del parámetro MV_ULTDEPR, por desactualización de la rutina ATFA060 o bien porque la variable  de la fecha de la ultima depreciación se esta generado de tipo lógico con un valor de .F. en lugar de ser de tipo Fecha y obtener el valor del parámetro MV_ULTDEPR.

atfa060rox.jpg



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1 Sugerimos tener la actualización de binarios y librerías disponibles en el portal del cliente, aplicados en su ambiente de pruebas inicialmente;

Downloads y atualizaciones de Librerias

Downloads y atualizaciones Binarios - APPSERVER

Downloads y atualizaciones Binarios - SMARTCLIENT

 


2. Verifique tener la rutina ATFA060 con fecha igual o superior al 08/10/2018;

Patch P12117_ATFA060_20181008_DSERCTR1-14935.ZIP 

 

3. En caso de descargar los patchs, deberá aplicar en su ambiente con previo respaldo del RPO, eligiendo la opción aplicar solo fuentes actualizados;



4. Verifique la configuración del parámetro MV_ULTDEPR, que sea de tipo Fecha, el parámetro por estándar no tiene asignado código de filial, sin embargo puede crear este parámetro de tipo fecha para cada una de sus filiales; 

MV_ULTDEP.jpg


5. Verifique tener desactivado el parámetro MV_TECATF

parametro.jpg



6. Ingrese nuevamente a la rutina Transferencias (ATFA060) valide el escenario reportado (Se anexa un ejemplo en vídeo de la validación de soporte).


Conozca más:
Para consultar la información contenida en el Help On-Line, acceda a los siguientes enlaces:

Help On-Line Transferencias (ATFA060)



¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _