Ocurrencia
En el módulo Stock/Costos, al intentar procesar el Cierre de Saldos de Stock para un período que todavía no ha sido cerrado utilizando la rutina MATA280, el sistema presenta el mensaje MA280DTFEC indicando que el proceso de cierre se ha completado a partir de la fecha especificada y no permite procesar.
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) – A partir de la versión 11.80
Causa
La rutina de Cierre de Saldos presenta el mensaje de que el proceso de cierre ya se ha completado porque existen registros de saldo inicial en SB9 con fecha a partir de la fecha informada en los parámetros de la rutina. Si existiera al menos un registro en la tabla SB9 con fecha igual o superior a la fecha informada en el Cierre de Saldos, la rutina presentará el mensaje indicando que el proceso ya ha sido completado.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Ingrese a la rutina de Saldos Iniciales MATA220;
2. Identifique los registros de saldo inicial con fecha dentro del período que está intentando procesar;
3. Analice el origen de dichos registros para evaluar si los mismos pueden ser revertidos;
4. Si después de analizar el origen de los registros no tiene problemas para revertirlos, haga un respaldo de su tabla SB9 y elimine dichos registros mediante la funcionalidad de la rutina o directamente en la tabla SB9 por APSDU;
5. Ejecute el proceso de Cierre de Saldos de Stock.
0 Comentarios