Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Activo FIjo (SIGAATF) - SN2010: SetOrder - Index not found. on AF012SN2(ATFA012.PRW) DD/MM/AAAA 14:21:45 line : 12670

Ocurrencia
En módulo Activo Fijo, al incluir un nuevo activo a través de la rutina ATFA012,  se genera el error:

SN2010: SetOrder - Index not found. on AF012SN2(ATFA012.PRW) DD/MM/AAAA 14:21:45 line : 12670


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Activo FIjo (SIGAATF) - Versión 12.1.14

Causa
Este incidente ocurre, por la ausencia del segundo indice en la tabla SN2


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Ingrese a APSDU y respalde la tabla SN2;

2. Aplique un DROP a la tabla SN2, una vez hecho su respaldo;

3. Ingrese a Configurador> Diccionario> Base de datos> Seleccione la tabla SN2 eligiendo la opción editar;

4. Cree el nuevo indice y grabe los cambios, recuerde tener el ambiente en modo exclusivo, salga del configurador;
sn2.jpg

SIXSN2.jpg

5. Ingrese al APSDU y modifique el campo X2_UNICO de la tabla SN2 en la SX2 de su ambiente, salga del APSDU;

Antes: N2_FILIAL+N2_CBASE+N2_ITEM+N2_TIPO+N2_SEQUENC
Después: N2_FILIAL+N2_CBASE+N2_ITEM+N2_TIPO+N2_SEQ+N2_SEQUENC

SX2_SN2.jpg

6. Ingrese al Activo Fijo> Actualizaciones> Activo> Incluya un nuevo activo fijo, valide que no sea generar el error.log;
grabaok.jpg

7. Incluya una descripción extendida, valide la grabación.
Descripcion_extendida.jpg


Conozca más:
Para consultar la información contenida en TDN, acceda al siguiente enlace:

Clave duplicada al grabar una descripción extendida vinculada a un activo fijo

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 1 de 1

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _