Ocurrencia
Al intentar ingresar al sistema Protheus se muestra el error Open – Ctree Error 920 – IO Error: 21 – File: ….. \ Sigamat.emp on MSOPENDBF
Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión 10 y posteriores
Causa
Este error se presenta principalmente por una des-conexión del servicio de Ctree y por la variación de registros encontrados en el sistema y el sigamat.emp. Suele presentarse cuando hay una configuración de un nuevo sigamat.emp.
Solución
Para la corrección del incidente se sugiere la ejecución de los siguientes pasos:
(Previamente a la ejecución se recomienda realizar el rebuild de Sigamat o aplicar la última LIB)
1.- Cerrar los sistemas que se encuentren en ejecución.
2.- Desactivar el Ctree server
3.- Eliminar la carpeta ctreeint del system (previo respaldo)
4.- Eliminar sigamat.ind
5.- Copiar el sigamat.emp liberado
6.- Realizar un Backup de todos los archivos cdx y dtc y eliminarlos de la carpeta system
7.- Iniciar los servicios, comenzando con el Ctree Server posteriormente el servidor Protheus
8.- Ingresar al sistema SIGACFG y crear todo el diccionario en todas las empresas
9.- Parar los servicios y colocar el Backup de todos los archivos cdx y dtc previamente respaldados.
10.- Iniciar los servicios nuevamente en el siguiente orden:
a)Ctree Server
b)Servidor de Licencias
c)Servidor Protheus
d)Y por ultimo Top Connect
11.- Ingresar al sistema y validar si el error ya no ocurra nuevamente.
0 Comentarios