Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

FRAMEWORK - Framework (Línea Protheus) MI - Open – Ctree Error 920 – IO Error: 21 – File: \ Sigamat.emp on MSOPENDBF

FRAMEWORK - Framework (Línea Protheus) MI - Open – Ctree Error 920 – IO Error: 21 – File: \ Sigamat.emp on MSOPENDBF


Ocurrencia
Al intentar ingresar al sistema Protheus se muestra el error Open – Ctree Error 920 – IO Error: 21 – File: ….. \ Sigamat.emp on MSOPENDBF

1.png


Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión 10 y posteriores

Causa
Este error se presenta principalmente por una des-conexión del servicio de Ctree y por la variación de registros encontrados en el sistema y el sigamat.emp. Suele presentarse cuando hay una configuración de un nuevo sigamat.emp.

Solución
Para la corrección del incidente se sugiere la ejecución de los siguientes pasos:
(Previamente a la ejecución se recomienda realizar el rebuild de Sigamat o aplicar la última LIB)

1.- Cerrar los sistemas que se encuentren en ejecución.

2.- Desactivar el Ctree server

3.- Eliminar la carpeta ctreeint del system (previo respaldo)

4.- Eliminar sigamat.ind

5.- Copiar el sigamat.emp liberado

6.- Realizar un Backup de todos los archivos cdx y dtc y eliminarlos de la carpeta system

7.- Iniciar los servicios, comenzando con el Ctree Server posteriormente el servidor Protheus

8.- Ingresar al sistema SIGACFG y crear todo el diccionario en todas las empresas

9.- Parar los servicios y colocar el Backup de todos los archivos cdx y dtc previamente respaldados.

10.- Iniciar los servicios nuevamente en el siguiente orden:

     a)Ctree Server

     b)Servidor de Licencias

     c)Servidor Protheus

     d)Y por ultimo Top Connect

11.- Ingresar al sistema y validar si el error ya no ocurra nuevamente.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _