Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

GPER015 - No permite seleccionar más de procedimiento de cálculo en la pregunta ¿Procedimiento? (MV_PAR01)



relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:15:00 min 


Ocurrencia
En el módulo Gestión de personal (SIGAGPE), al generar el Libro de Sueldo Digital (GPER015) no permite seleccionar más de procedimiento de cálculo en la pregunta ¿Procedimiento? (MV_PAR01)


Entorno
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - Versión 12


Causa 
Este incidente ocurre, porque desactualización de la rutina GPER015 y/o ajuste al diccionario de datos en el grupo e peguntas GPER015B y las consultas estandar (SXB) RCHLSP - Periodo LSD y RCHLSN - Nro Pago LSD


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:


1. Solicite la actualización de la rutina GPER015 con fecha igual o superior a 27/02/2025, vía ticket a Soporte Protheus Mercado Internacional (ISSUE - DNOMI-3135 / DNOMI-2215);

- Solución liberada: 

Boletín técnico DT Actualización en la Generación de Archivos del Libro de Sueldo Digital (GPER015) ARG

Se implementa la generación de un archivo ".txt" por cada Tipo de Procedimiento informado en la pregunta "¿Procedimiento?". Para que cada archivo generado, se le asigne un nombre de la siguiente forma: _.txt
Ejemplo: 202401_01_LIQ_00001.txt o 202401_01_SAC_00001.txt



2. Mediante el Configurador (SIGACFG), realizar las siguientes actualizaciones en el Grupo de Preguntas (SX1) GPER015B;
 

Orden

Título

Tipo

Tamaño

Modo

Validación

Consulta

Variable

Def. 01

Def. 02

Def. 03

Inicializador

1

¿Procedimiento?

C

99

Rango

NaoVazio()

SRY

MV_PAR01

 

 

 

 

2

¿Proceso?

C

5

Edit

NaoVazio() .And. ExistCpo("RCJ",MV_PAR02,1)

RCJ

MV_PAR02

 

 

 

 

3

¿Periodo?

C

6

Edit

NaoVazio()

RCHLSP

MV_PAR03

 

 

 

 

4

¿Número de Pago?  

C

2

Edit

NaoVazio()

RCHLSN

MV_PAR04

 

 

 

 

5

¿Tipo Liquidación?

C

1

Combo

 

 

MV_PAR05

M=Mensual

Q=Quincenal

S=Semanal

2

6

¿Ruta del Archivo?

C

99

Edit

 

HSSDIR

MV_PAR06

 

 

 

 

7

¿Identificación de Envío?

C

1

Combo

 

 

MV_PAR07

1 - SJ

2 - RE

 

1


 

3. Garantice tener creadas y correctamente configuradas las consultas estandar:

  •  RCHLSP - Periodo LSD

Tipo

Secuencia

Columna

Descripción

Contenido

1

1

DB

Periodo LSD         

RCH

2

1

1

Proceso + Cód. Perio

 

4

1

1

Cód. Periodo

RCH_PER

4

1

2

Número pago

RCH_NUMPAG

4

1

3

Proced Calc

RCH_ROTEIR

4

1

4

Proceso

RCH_PROCES

4

1

5

Orden LSD           

RCH_ORDLSD                     

4

1

6

Fecha pago

RCH_DTPAGO

4

1

7

Fch. Cierre

RCH_DTFECH

5

1

 

 

RCH->RCH_PER                         

5

2

 

 

RCH->RCH_NUMPAG

6

1

 

 

RCH->RCH_PROCES==MV_PAR02

 

  •  RCHLSN - Nro Pago LSD:

Tipo

Secuencia

Columna

Descripcion

Contenido

1

1

DB

Nro Pago LSD               

RCH

2

1

1

Proceso + Cód. Perio

 

4

1

1

Cod. Periodo

RCH_PER

4

1

2

Número pago

RCH_NUMPAG

4

1

3

Proced Calc

RCH_ROTEIR

4

1

4

Proceso

RCH_PROCES

4

1

5

Orden LSD           

RCH_ORDLSD                     

4

1

6

Fecha pago

RCH_DTPAGO

4

1

7

Fch. Cierre

RCH_DTFECH

5

1

 

 

RCH->RCH_NUMPAG

6

1

 

 

RCH->RCH_PROCES==MV_PAR02







 

Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:

TDN - DT Localización Argentina (SIGAGPE) - Protheus 12

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _