Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - ORA-00001: unique constraint (SYSTEM.CQ8010_UNQ) violated



relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:03:00 min 

Ocurrencia
Al correr el proceso de contabilidad offline se presenta el siguiente error log:

THREAD ERROR ([1289066], , oc) 03/04/2025 12:30:47
CQ8010: DB error (Insert): -37 File: CQ8010 - Error : 1 - ORA-00001: unique constraint (SYSTEM.CQ8010_UNQ) violated
( From tISAMFile::Write )
Thread ID [11587] User [Administrador] IO [4811] Tables [119] MaxTables [119] Comment [CTBAFIN - TCPIP - ThreadID(1289066)] SP [ ] Traced [No] SQLReplay [No] InTran [Yes] DBEnv [ORACLE/DADOSDES] DBThread [(SID 333,25804,1)] Started [03/04/2025 12:30:12] IP [10.254.2.65:10000] IDLE [ ] InTransact [0 s.] Memory [0] Running [ROP_WRITE for 0 s.] RCV [263059] SND [956154] TCBuild [20240224-20241002] TCVersion [24.1.0.0] ARCH [64] OS [LINUX] BUILD [RELEASE]
INSERT INTO CQ8010(CQ8_FILIAL,CQ8_IDENT,CQ8_CODIGO,CQ8_DATA,CQ8_MOEDA,CQ8_TPSALD,CQ8_LP,CQ8_STATUS,CQ8_SLBASE,CQ8_DEBITO,R_E_C_N_O_) VALUES ( :1,:2,:3,:4,:5,:6,:7,:8,:9,:10,:11)
-- Binded Parameters List --
#1 [C] [01]
#2 [C] [CTT]
#3 [C] [1010101 ]
#4 [D] [20250331]
#5 [C] [01]
#6 [C] [1]
#7 [C] [N]
#8 [C] [1]
#9 [C] [S]
#10 [N] [1000.000000]
#11 [R] [6]
- Integrity failure. on MSUNLOCK(APLIB060.PRW) 14/03/2025 17:19:03 line : 736

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - versión 12

Causa
Este error en la tabla CQ8 comúnmente está relacionado con el tamaño de las entidades, Centro de Costo, Item contable y Clase de Valor, ya que varios módulos usan estas entidades contables y para grabar en las tablas CQ8 y CQ9 no puede haber diferencias en el tamaño.

Solución

Para solucionar esa ocurrencia, realice los siguientes pasos, inicialmente en un ambiente de pruebas y con previo respaldo de sus tablas::

  1. Ingrese al Configurador >Base de datos>Diccionario>Base de datos>Grupo de campos
  2. Valide que las entidades contables Centro de costo, ítem contable y clase valor estén homologados en tamaño, si hay diferencias deberá ajustar el tamaño siempre siguiendo el tamaño de la entidad más grande entre las 3.

    Por favor lea detalladamente y siga el siguiente artículo:

    Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - CFGX031 - ¿Cómo homologar el tamaño de campos de los entes contables (CTBA005)?

    Es importante garantizar y revisar que los campos se encuentren homologados para el correcto funcionamiento.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _