Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - CFGA510 - Error.log "SYS_USR: DB error (Insert): -37 File: SYS_USR - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:01:30 min 

Ocurrencia
En el módulo Configurador al intentar incluir un usuario se detona el error.log  "SYS_USR: DB error (Insert): -37 File: SYS_USR - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.SYS_USR' with unique index 'SYS_USR_UNQ'."


Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - A partir de versión 12

Causa
Este incidente ocurre por inconsistencias en correlativos de numeración de tabla de usuarios

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1.- Confirmar que el control de numeración se encuentre de forma correcta.
Ingrese a la rutina de usuarios y confirme ¿Cuál es el último registro que tiene para los usuarios?
Ingrese a rutina APCFG110 - Control de Numeración
Localice el alias SYS_USRUSR_ID como se muestra en la imagen adjunta y realice el ajuste de los consecutivos



2.- Así mismo, es importante mencionar, que este desajuste en la numeración, puede ser ocasionado porque exista más de una base de datos, compartiendo el License Server, ocasionando conflictos en los consecutivos, para este caso, puede revisar el siguiente artículo, en caso de requerir que el sistema pueda identificar sobre qué alias de la base de datos tomará el número consecutivo de la numeración.
FRAMEWORK - Framework (Línea Protheus) MI - Configuración de cláusula SpecialKey

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _