Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - MATA486 - Error en la configuración de la Integración del Protheus al Totvs ServicesWSCERR047/XML Error Extra content at the end of the document



relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:03:00 min 

Ocurrencia
Al realizar la configuración para la transmisión electrónica con TSS a través de la rutina MATA486, después de capturar los datos (URL del servidor TOTVS Services, certificado digital, contraseña y ambiente) al dar clic en avanzar, se presenta el siguiente error:

Error en la configuración de la Integración del Protheus al Totvs ServicesWSCERR047/XML Error Extra content at the end of the document (POST in localhost:8080/NFECFGLOC.apw )

HEADER:[HTTP/1.1 200 OK

Date:
Server: Application Web Server
MIME-version: 1.0
Content-type: text/xml; charset=utf-8
Last-modified:
Set-cookie: SESSIONID=XXXXXXXXXXXXXXXXXXXXXXXX
XAPWSBUILD: ADVPL WSDL Server 1.110216
X-Frame-Options: SAMEORIGIN
Content-Length: 75
] POST-RETURN: [

invalid proc return
]
ADVPL WSDL Client 1.120703/TOTVS Servicios MSSQL per_mir2310 on




Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - versión 12

Causa
El error es causado por que la dbapi.dll que se encuentra en el appserver de la instalación de TSS esta más desactualizado que la dbapi.dll del DBAccess.

Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:

  1. Inicialmente sugerimos revisar el console.log del appserver de TSS.
  2. En este caso se identifico que al intentar realizar la configuración para la transmisión electrónica, se detonaba el siguiente error:

    Error - TOPCONN - No connection: -97 - DBAPI_OUTDATED : Connection blocked. The DBAPI [20230303] used on the application server is out of date.

  3. Para solucionar el error del punto 2, si ya tiene su DBAccess actualizado acceda a la carpeta TOTVSDBAccess\CLIENT y copie el archivo (dbapi.dll)

  4. Acceda a la carpeta TSS Appserver y pegue el archivo (dbapi.dll), se sugiere respaldar previamente la dbapi.dll anterior.

  5. Posteriormente, reinicie los servicios DBAccess y TSS, realice una nueva prueba.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _