Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Línea Protheus) - MI - ADVPL - Type mismatch on XXXX

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:05:00 min 

Ocurrencia
Error type mismatch on XXXX

Entorno
Cross Segmentos - TOTVS Backoffice (Línea Protheus) - MI - ADVPL - A partir de la versión 12.1.33

Causa
Ocurrencias de esta naturaleza se reproducen cuando una expresión ADVPL intenta realizar operaciones de comparación y/o cálculo utilizando más de un argumento de tipos incompatibles.
Por ejemplo, agregar una cadena a un número ( no coinciden los tipos en +), comparar una fecha con un valor booleano ( no coinciden los tipos en comparar ), usar un operador de inversión booleano con un argumento no booleano ( no coinciden los tipos en .NOT ).

Solución
Debe de realizarse una revisión manual para los operadores de comparación, apoyarse con los logs que arroja el sistema y visualizar la comparativa errónea.

Observación: Los operadores de comparación permiten comparar argumentos de diferentes tipos, siempre que uno de los argumentos sea NIL (U), y los operadores de suma y resta permiten estas operaciones con argumentos de tipo Fecha y Numérico, en ese orden, dando como resultado una expresión de el tipo de fecha.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _