Tiempo aproximado de lectura 00:03:00 min
Ocurrencia
Al intentar timbrar una factura desde WebApp se presenta el siguiente mensaje de error:
Error al intentar timbrar desde WebApp No existe cliente de servicio web C:\Users\usuario\AppData\Local\Programs\web-agent\TimbradoFormasDigitales.exe no es posible continuar con el timbrado.
Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - a partir de versión 12.1.2210
Causa
Este incidente ocurre porque el ejecutable no se encuentra en la ruta correcta del web-agent
Solución
Para solucionar esa ocurrencia, realice los siguientes pasos:
- Verifique que el parámetro MV_CFDSMAR este configurado con el valor GetClientDir()
- Localice la ruta indicada en el mensaje de error, siguiendo con el ejemplo del articulo la ruta es la siguiente:
C:\Users\magdalena.lopez\AppData\Local\Programs\web-agent
- Si al ingresar a la carpeta del usuario no visualiza la carpeta de AppData:
Sugerimos activar la vista de los elementos ocultos, ejemplo:
- Una vez visualice la carpeta AppData ingrese a las carpetas Local\Programs\web-agent
- Coloque el ejecutable de timbrado del PAC así como sus DLL o librerías que requiera, para este ejemplo se esta empleando el PAC Formas Digitales, en este caso solo es necesario el ejecutable TimbradoFormasDigitales.exe
- Valide que el mensaje de error ya no se presente.
CONOZCA MÁS
Ubicación de archivos en Web-Agent/SmartClient Web
En adjunto a este articulo se comparte un video de ejemplo
0 Comentarios