Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBR040-Data width error - Field: SALDOATUDB Value: 0000000000000000.000000 on CTCONTASUP(CTBXSAL.PRW)



time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia

Al generar el balance modelo 1 (CTBR040) se presenta el siguiente error log:

THREAD ERROR ([10282], USER, BOG000103) 23/08/2024 12:38:55
Data width error - Field: SALDOATUDB Value: 1000000041873616.000000 on CTCONTASUP(CTBXSAL.PRW) 13/09/2022 15:15:39 line : 122

[TOTVS build: 7.00.210324P-20240219]
Called from CTGERPLAN(CTBXSAL.PRW) 13/09/2022 15:15:39 line : 1805
Called from {| OMETER, OTEXT, ODLG, LEND | CTGERPLAN(OMETER, OTEXT, ODLG, @LEND,@CARQTMP, MV_PAR01,MV_PAR02,"CT7","",MV_PAR03,MV_PAR04,,,,,,,MV_PAR08, MV_PAR10,ASETOFBOOK,MV_PAR12,MV_PAR13,MV_PAR14,MV_PAR15, .F. , .F. ,MV_PAR11,,LIMPANTLP,DDATALP,NDIVIDE,LVLRZERADO,,,,,,,,,,,,,,LIMPSINT,CFILUSER,LRECDESP0, CRECDESP,DDTZERARD,,,,,,,CMOEDADSC,,ASELFIL)}(CTBR040.PRW) 28/06/2023 16:54:37 line : 530
Called from {|| OTEXT:REFRESH(),OMETER:REFRESH(),EVAL( BACTION, OMETER, OTEXT, ODLG, @LEND ),LEND := .T. , ODLG:END() }(MSLIB.PRW) 28/12/2023 11:04:56 line : 122
Called from ::MSDIALOG:ACTIVATE
Called from MSGMETER(MSLIB.PRW) 28/12/2023 11:04:56 line : 124
Called from REPORTPRINT(CTBR040.PRW) 28/06/2023 16:54:37 line : 530
Called from { |OREPORT| PERGUNTE(CPERG , .F. ), IF(! REPORTPRINT( OREPORT, WNREL ), OREPORT:CANCELPRINT(), .T. ) }(CTBR040.PRW) 28/06/2023 16:54:37 line : 212
Called from {|| IIF(SELF:INIT(),(LACTION := EVAL(SELF:BACTION,SELF),SELF:FINISH()),LOK:= .F. ),LEND := .T. ,ODLG:END()}(REPORT01.PRW) 28/12/2023 11:04:56 line : 2246
Called from ::MSDIALOG:ACTIVATE
Called from TREPORT:PRINT(REPORT01.PRW) 28/12/2023 11:04:56 line : 2259
Called from TREPORT:PRINTDIALOG(REPORT01.PRW) 28/12/2023 11:04:56 line : 3523
Called from CTBR040R4(CTBR040.PRW) 28/06/2023 16:54:37 line : 120
Called from CTBR040(CTBR040.PRW) 28/06/2023 16:54:37 line : 62
Called from __EXECUTE(APLIB090.PRW) 28/12/2023 11:04:55 line : 733
Called from MDIEXECUTE(APLIB260.PRW) 28/12/2023 11:04:55 line : 924



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - versión 12

Causa
Este incidente se presenta cuando en el Plan de Cuentas (Tabla CT1) se tienen cuentas que tienen la misma cuenta asignada como cuenta superior, ejemplo:

 

Solución

 

Para solucionar esa ocurrencia, realice los siguientes pasos:

  1. Localice las cuentas que tienen asignada la misma cuenta como cuenta superior, puede validarlo a través de una consulta en su gestor de base de datos, ejemplo:

    SELECT CT1_CONTA, CT1_CTASUP, * FROM CT1010 WHERE CT1_CONTA=CT1_CTASUP


  2. Ingrese a la rutina Plan de Cuentas (CTBA020)
  3. Localice cada una de las cuentas identificadas con la misma cuenta superior asignada.
  4. Elimine la cuenta superior (CT1_CTASUP) de cada una de las cuentas identificadas con la misma cuenta superior asignada.
  5. Grabe cambios.
  6. Valide nuevamente la ejecución del informe.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _