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Ocurrencia
El Stored Procedure 18 marca error de incompatibilidad y posterior a la instalación 'Forzada' del Stored, se mantiene como desactualizado
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - A partir de la versión 12.1.33
Causa
Este incidente puede ser ocasionado debido a la configuración de la actualización de los Stored en base a la Central de Actualizaciones
Solución
Inicialmente es importante considerar que el Stored 'desactualizado' no representa un error y su actualización no es considerada obligatoria ni urgente. Estos procedures con dicho estatus pueden ser ejecutados sin ningún problema por la rutina que lo usa
En dicho caso, esto ocurre debido a que el proceso instalado en el ambiente no esta en su versión mas reciente disponibilizada por TOTVS lo que significa que el pacote instalado es reconocido como una versión inferior del último pacote homologado. Este proceso generalmente ocurre en un ambiente con la actualización 'online', es decir realizada con los pacotes disponibles de la Central de Actualizaciones, por lo tanto se mostrara algún Stored como desactualizado pues el proceso recientemente homologado estará disponible para su uso inmediatamente posterior a su publicación (Es decir, inicialmente pasan por un proceso de aprobación y posterior a publicación del patch correspondiente) mientras tanto la herramienta genera una lectura en tiempo real (desde la aprobación) aun cuando haya sido aplicado o no algún patch en el ambiente
En dicho caso, para los Stored que se muestran como incompatibles, se sugiere realizar el mismo proceso de la opción del engranaje ("Forzar el uso de los pacotes ZSPS contenidos en el RPO") pues ahora la actualización se basara y mantendrá en lo contenido por el RPO. Es posible que vuelva a visualizar el Stored como 'desactualizado' sin embargo como fue compartido, esto no corresponde a un error
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