Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - Error al ingresar a la rutina Generación de Notas, variable does not exist on FWBRWTABLE.PRW


time.png Tiempo aproximado para lectura: 1:30 min

Ocurrencia
En el módulo Facturación de un ambiente localizado para Mercado Internacional, al ingresar a la rutina de Generación de Notas MATA468N, después de confirmar los parámetros para generar la factura a partir de Pedido de Venta, ocurre el error "variable does not exist" haciendo referencia a algún campo de la tabla SD2 y a la rutina FWBRWTABLE.PRW.

Sigue un ejemplo del error:
variable does not exist D2_DOC on {||(( D2_DOC>= "0000001070262" .AND. D2_DOC<= "0000001070301" ) .OR. ( D2_DOC>= "0000001070207" .AND. D2_DOC<= "0000001070240" ) )}(FWBRWTABLE.PRW) 04/10/2022 11:41:06 line : 736

img01.png

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - Versión 12

Causa
El error ocurre porque se tienen filtros marcados en el Browse de la rutina que corresponden a Guías de Remisión, Remitos de Salida o Guías de Despacho.

Solución
Para solucionar el error, ingrese nuevamente a la rutina de Generación de Notas MATA468N, pero, esta vez en lugar de seleccionar Pedidos, seleccione la opción Remito o Guía de Despacho:

02.png

Verifique si hay filtros aplicados, en caso afirmativo, desmarque los filtros y salga de la rutina:

03.png

Ingrese nuevamente a la rutina con la opción de Pedidos y verifique que no ocurra el error:

04.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _