Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) - MI - APPSERVER - Al modificar el tamaño de un grupo de campos, no se refleja el ajuste en la base SQL


time.png Tiempo aproximado para lectura: 00:02:30 min

Ocurrencia
Al modificar el tamaño de un grupo de campos, el ajuste solo es reflejado en las tablas SX3 y SXG, sin embargo al visualizar a través de la BD, estos no fueron ajustados

 

Ambiente
FRAMEWORK - Framework (Línea Protheus) - MI - APPSERVER - A partir de la versión 12

 

Causa
Este incidente puede ocurrir en entornos migrados y una inconsistencia durante el proceso de migración

 

Solución
Para solucionar este incidente, realice lo siguiente:

1.- Realice un respaldo de su BD  (Confirme que es la base donde se realizará esta prueba)

2.- Realice un respaldo de la tabla donde visualiza que no fue ajustado el tamaño del campo
3.- Realice un Drop/Elimine esta tabla
4.- Acceda al sistema para regenerar la tabla 
5.- Appende los registros respaldados
6.- Verifique que tanto en las tablas SX3 y SXG se mantenga el tamaño modificado
7.- Valide que en SQL también se vea cambiado el tamaño modificado para el campo involucrado en el grupo de campos 

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _