Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - Data width error, campos B2_VATU con valores muy altos inclusive negativos


time.png Tiempo aproximado para lectura: 5:00 min

Ocurrencia
Al intentar grabar algún movimiento que actualiza stock en cualquier rutina/módulo del Sistema, ocurre el error "Data width error - Field:" haciendo referencia a los campos B2_VATU en cualquiera de sus 5 monedas (B2_VATU1, B2_VATU2, B2_VATU3, B2_VATU4 o B2_VATU5) expresando valores excesivamente altos e inclusive negativos. Ejemplos:

erro.png

02.png

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - Versión 12

Causa
Este tipo de errores comúnmente ocurren por inconsistencia de información en la base de datos, por ejemplo, porque existen productos con valores muy altos, a veces negativos, ya grabados en la tabla de saldos físico/financiero SB2.

Solución
Para solucionar esta ocurrencia, es necesario identificar cuál es el producto que tiene la inconsistencia y cuáles son los campos de SB2 que tienen los valores altos/negativos para después hacer el ajuste.

Para identificar el producto con el problema, busque en el archivo log del error generado (error.log).

Si el Sistema no presentó el log del error en pantalla, el mismo puede encontrarlo normalmente en la carpeta system del ambiente conforme indica la ventana que muestra el error:

image.png

Una vez abierto el error.log, busque por B2_COD hasta llegar a los datos de la tabla SB2, ahí podrá verificar cuál es el producto que tiene el problema y cuáles son los campos con valores inconsistentes. Ejemplo de un error generado donde se puede observar el detalle del producto y los campos incorrectos:

img2.png

Una vez que haya identificado el producto y los valores incorrectos, para solucionar el error, realice un ajuste de stock valorizado para su producto a través de la rutina de movimientos internos MATA241, informando un valor lo suficientemente elevado para contrarrestar el valor que existe actualmente en su ambiente.

Por ejemplo, suponiendo que su producto actualmente tiene un valor almacenado en B2_VATU1 de -800500224.00 y su valor correcto debería ser 1000.00, entonces debe incluir un movimiento interno valorizado de stock por cantidad 0 y valor 800501224.00, de esa manera al hacer la operación -800500224.00 + 800501224.00 resultará el valor de 1000.00 que ajustará el saldo actual en SB2 para su producto.

Conozca más
En las siguientes documentaciones encontrará mayor detalle acerca del procedimiento de ajuste de stock valorizado que se sugiere en el presente artículo, así como también, otras alternativas de solución para el error presentado:
TDN: Como resolver la ocurrencia "Data width error - Field: B2_VATU2 / B2_QATU"
Artículo: Como resolver error "Data Width error - Field: B2_VATU1/B2_VATU2/B2_VATU3/B2_VATU4/B2_VATU5"?

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _