Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - Campo de Imagen habilitado para edición en Visualización

time.png Tempo aproximado de lectura: 00:05:00 min

Ocurrencia

Tengo un error en un campo de imagen, donde estoy incluyendo una imagen que no se cambiará, cuando accedo a la opción del menú Ver, la edición del campo queda disponible aunque verifiquemos con X3_WHEN Rellenado igual a falso tampoco deshabilita la edición.

mceclip0.png

Ambiente
FRAMEWORK - Framework (Línea Protheus) MI- Todas las versiones 12

Causa 

El problema se presenta debido a que se utiliza la variable aRotina como PRIVATE , luego el comportamiento del programa que controla el El campo BITMAP asumió el comportamiento para programas que no son MVC. Solo en funciones heredadas debes usar esta variable como PRIVATE .

 

Solución

Para corregir el problema, se debe cambiar el programa custom, de la siguiente manera:

En la Función de Usuario:
* Eliminar la línea: Private aRotina := MenuDef()
* ​​​​Agregar la línea 
oBrowse:SetMenuDef( 'PRWNAME' ), después de la declaración del objeto FwMBrowse() y reemplazando la cadena 'PRWNAME' con la nombre del archivo .prw que en este caso tiene la función MenuDef() estática deseada.

mceclip1.png

Obtenga más información sobre la sintaxis del método SetMenuDef

examinar:SetMenuDef(< cMenuDef >)-> NIL

Descripción
Indica el programa que se utilizará para cargar el menú funcional.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _