Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) - Data width error - Field: A2_MATR Value: xxxx.xxxxxx on ATUASALDOS(FINA850.PRW)


time.png Tiempo aproximado para lectura: 00:02:30 min

Ocurrencia 

Al intentar realizar un Pago Automático se detona el errorlog: "Data width error - Field: A2_MATR Value: 45273.000000 on ATUASALDOS(FINA850.PRW)" 

 

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) - A partir de la versión 12 

Causa
Este incidente ocurre porque se excedió el tamaño límite del campo

Solución
Para solucionar esta ocurrencia, puede validar las siguientes alternativas: 

1.- Ajuste el tamaño y decimal referente al error mostrado (Acorde a los dígitos del error)
 
Ejemplo:
Error log: 1234567890123.000000
Tamaño = 13
Decimal = 6 

O bien,

2.- Verifique la pila de llamadas del campo vencimiento y fecha de vencimiento real, puede deberse también a que las fechas están muy alejadas entre sí, desbordando el contenido de los campos al realizar el proceso por lo cual, también puede realizar el ajuste la fecha de vencimiento o como es mencionado el aumento del campo A2_MATR 

 

Imagen de ejemplo para verificar el desbordamiento generado debido a los campos no definidos en la fecha vencimiento o vencimiento real 

chrome_Q6QnG1ZJlf.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _