Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

FRAMEWORK - Framework (Línea Protheus) - MI - SMARTCLIENT - Error: 39 - The four-byte data record position address space has been exhausted on FLUSHSXPLOG(APLIB200.PRW)

FRAMEWORK - Framework (Línea Protheus) - MI - SMARTCLIENT - Error: 39 - The four-byte data record position address space has been exhausted on FLUSHSXPLOG(APLIB200.PRW)


time.png Tiempo aproximado para lectura: 00:02:30 min

Ocurrencia 
Al acceder a cualquier rutina del sistema, se detona el errorlog "Ctree Error - Insert - File: c:\...\protheus_data\...\system\sxp010.dtc - Error: 39 - The four-byte data record position address space has been exhausted on FLUSHSXPLOG(APLIB200.PRW) "

 

Ambiente
FRAMEWORK - Framework (Línea Protheus) - MI - SMARTCLIENT - A partir de la versión 12 

Causa
Este error ocurre debido al tamaño de los archivos SXO y SXP, estos archivos de registro tienen una limitación natural ya que son DBF o DTC (Dbf hasta 2gb y Dtc 4gb)

Solución 
Para corregir esta ocurrencia, es necesario cambiar el nombre de estos archivos SXO y/o SXP en el directorio (System) y validar nuevamente el acceso al sistema y rutinas

 
Es recomendable valide inicialmente en un ambiente controlado de pruebas con previo respaldo de su ambiente

 

chrome_FbQZEaxbHJ.png
 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _