Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - AppServer Multiprotocolo activado no inicia en ambiente linux: Function error (|Cant connect on Lock Server in file ../../../advpl/publicenv.cpp

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
Al actualizar Appserver para sistema operativo Linux y habilitar el puerto multiprotocolo, no es posible iniciar el servicio deronando error: Function error (|Cant connect on Lock Server in file ../../../advpl/publicenv.cpp

 



Ambiente
FRAMEWORK - Framework (Línea Protheus) MI - A partir de versión 12

Causa
Este comportamiento ocurre debido a la configuración LockServer del archivo appserver.ini

Solución:

A partir de la versión 20.3.1.0 de TOTVS | Application Server, no es necesario utilizar LockServer en entornos Linux
Para desactivar el uso de LockServer en TOTVS | Application Server, se debe configurar la sección LOCKSERVER con las claves Enable=0 y Server=NOCONFIG (en mayúsculas).
 
Para mayor detalle consulte el siguiente enlace:
 
https://tdn.totvs.com/pages/viewpage.action?pageId=6064850

Para solucionar el incidente, deberá deshabilitar la configuración del LockServer en su ambiente.

Ejemplo de configuración: 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _