Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Activo Fijo (SIGAATF) - ATFA240 - Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]El nombre de columna 'N1_BMCONTR' no es válido

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
En la ejecución de la rutina ATFA240-Clasificación de compras, al intentar hacer la "Clasificación en lote" a través de la opción Otras acciones>Clasificación en lote.
 
Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]El nombre de columna 'N1_BMCONTR' no es válido.
 
THREAD ERROR ([6984], isabel.carvajal, 732ZK132020) 18/09/2023 11:37:19
: Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]El nombre de columna 'N1BMCONTR' no es válido. Error : 8180 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]No se puede preparar la instrucción o instrucciones. Error : 8180 (00000) (RC=-1) - ( From tODBCStatement::SqlBind ) Thread ID [2004] User [Administrador] IO [2709] Tables [59] MaxTables [60] Comment [ATFA240 - TCPIP - ThreadID(6984)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/R2210ARG] DBThread [(SPID 71,72,74)] Started [18/09/2023 11:36:24] IP [192.168.0.7:2210] IDLE [ ] InTransact [ ] Memory [0] Running [ROP_QUERY2 for 0 s.] RCV [91290] SND [450903] TCBuild [20220303-20230623] TCVersion [22.1.1.5] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
on VLDCANCLAS(ATFA240.PRX) 19/07/2023 15:10:35 line : 1286



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Activo Fijo (SIGAATF) - A partir de versión 12.1.2210

Causa
Este incidente se presenta por inconsistencias a nivel código que hace llamado a campo N1_BMCONTR el cual es de uso exclusivo de país Brasil.

Solución

Para solucionar esta ocurrencia, realice los siguientes pasos

1. Deberá ser aplicado el PATCH de expedición continua con publicación igual o superior a 29/09/2023 del módulo Activo Fijo publicado en Central de Descarga Totvs:

Central de Descarga - SIGAATF EXPEDICAO CONTINUA - TOPCONNECT

2. Aplicar las actualizaciones correspondiente, en su ambiente de pruebas inicialmente, con previo respaldo del RPO aplicando sólo fuentes actualizados.

4. Valide nuevamente el proceso para nuevos registros y confirme resultados.

 

Conozca más

Consulte el boletin técnico de TDN con la solución:

TDN - DSERCTR1-43241 DT ATFA240 - Não é possível utilizar mesmo código e item de bens para classificação em lote

Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
TDN - Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Configurador (SIGACFG) - Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _