Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - Componentes - COMPILEERROR-300 Failed to obtain exclusive access to the objects repository

time.png Tiempo aproximado de lectura: 00:05:00 min

Ocurrencia

Al intentar realizar una compilación en el ambiente por medio de Visual Studio, la conexión arroja el mensaje:

The process cannot access the file because it is being used by another process.COMPILEERROR-300 Failed to obtain exclusive access to the objects repository

 

Ambiente
FRAMEWORK - Framework (Línea Protheus) MI - Componentes - Todas las versiones 12

Causa
Este incidente puede ser causado por falta de configuraciones en los archivos INI del ambiente o por la configuración del server en Visual Studio 

Solución
La siguiente configuración es aplicable a ambientes con Brokers o Slaves configurados.

Inicialmente valide si el entorno Multiprotocolo esta activo en el ambiente, en el archivo Appserver.ini, si es así dependiendo del valor en el tag MultiProtocolPortSecure deberá seguir la configuración adecuada:

MultiProtocolPortSecure = 0:

Appserver.ini

[Drivers]
Active=TCP
MultiProtocolPort=1
MultiProtocolPortSecure = 0

 

Server Visual Studio

"id": "a0r4qyotd9sll3ye0qsth4i9kz9k5a",
"type": "totvs_server_protheus",
"name": "ENTORNO 2210",
"port": 1221,
"address": "192.168.10.168",
"buildVersion": "7.00.210324P",
"secure": false,

 

Smartclient.ini

[TCP]
server=127.0.0.1
port=1234
secureConnection=0

 

MultiProtocolPortSecure = 1

Appserver.ini

[Drivers]
Active=TCP
MultiProtocolPort=1
MultiProtocolPortSecure = 1

 

Server Visual Studio

"id": "a0r4qyotd9sll3ye0qsth4i9kz9k5a",
"type": "totvs_server_protheus",
"name": "ENTORNO 2210",
"port": 1221,
"address": "192.168.10.168",
"buildVersion": "7.00.210324P",
"secure": true,

 

Smartclient.ini

[TCP]
server=127.0.0.1
port=1234
secureConnection=1

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _