Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Facturación (SIGAFAT) - Atención: El registro X File X está bloqueado por otro usuario.

time.png Tiempo aproximado de lectura: 00:05:00 min

Ocurrencia
Atención: El registro X File X está bloqueado por otro usuario.

imagen2017-9-27_13-54-38.png

Ambiente
 - Todas las versiones 12 

Causa
El mensaje "El número de registro del archivo X está bloqueado por otro usuario" indica que la rutina ha intentado acceder a un registro, pero está reservada por algún procesamiento de otro usuario:

Solución

Este mensaje se puede mostrar en las siguientes situaciones:

 

1er Registro bloqueado por el uso de otro usuario / instancia arrestado

Para identificar si otro usuario está utilizando este registro es posible analizar la herramienta DBACCESS Monitor (DBAccess - Monitor > Users > Locks tab), tiene una opción para rastrear los bloqueos del usuario y la rutina accedida:

2ª Configuración de Parámetros que ayudan en la reserva de registros

  • MV_GNRENF: Si está desactivado, recomendamos habilitarlo (.T.), no mostrar la pantalla para cambiar los datos de GNRE / DIFAL (https://tdn.totvs.com/x/FvIGDg);
  • MV_FATTRAV: El parámetro MV_FATTRAV optimiza los bloqueos de registros de las tablas SA1 (Clientes), SA2 (Proveedores) y SB2 (Saldos). Por ejemplo, en la emisión de un Documento de Salida, con diez elementos, el MV_FATTRAV vacío, el sistema realizó 28 Bloqueos en la transacción. Al establecer el MV_FATTRAV en 4, el número de bloqueos se reduce a 19.

 

 Personalizaciones / Personalizaciones en su entorno.

    • Personalización por punto de entrada:
      Algunas personalizaciones utilizan los comandos dbSeek, MsSeek, dbGoTo, etc., que deponen los registros de tabla utilizados en las rutinas de producto estándar que causan el problema "EOF Stack in MSRLock". Para este caso, le recomendamos que utilice un RPO limpio sin personalizaciones para comprobar si el problema se debe a alguna personalización.

 

    • Personalización del diccionario de datos:
      compruebe si hay personalizaciones en Protheus Framework, como índices (SIX) o desencadenadores (SX7).
      Haga una copia de seguridad de los archivos en la carpeta del sistema y vuelva a compilarlos con un diccionario de datos estándar a actualizado. Rehacer el proceso.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _