Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - MATA467n - Validación errónea para campo F2_TPDOC cuando no se utiliza facturación electrónica en país Bolivia MV_CFDUSO=0

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
En módulo Facturación en ambiente de localización Bolivia cuando no se requiere realizar configuración de factura electrónica MV_CFDUSO=0, se detona validación errónea, referente al campo F2_TPDOC. El valor no existe en catálogo: S008.



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - A partir de versión 12.1.33


Causa
El error se presenta por inconsisencias en el inicializador estándar del campo, en el cual no se verifica si se realiza facturación electrónica o no, mediante el parámetro MV_CFDUSO.

 

Solución
Para solucionar esta ocurrencia, de forma controlada y con previo respaldo de su diccionario de datos, realice los siguientes pasos.

1. Ingrese al Módulo Configurador en el menú "Base de Datos> Diccionario>Base de datos", realizar la modificación de los campos F2_TPDOC, para el inicializador estándar con el Valor: IIF(SuperGetMv("MV_CFDUSO",.F.,"0")<> '0',IIF(ALLTRIM(M->F2_ESPECIE) == 'NDC', '18','1'),'')


2. Grabe la actualización al Diccionario

3. Confirme que cuando no se utilice factura electrónica (MV_CFDUSO=0) el campo F2_TPDOC será inicializado con valor "Vacío" en el alta de la Factura de Salida (Ventas), por lo que no será detonada la validación

 

Para mayor información, consulte el Boletín Técnico:

TDN - DMICNS-17100 DT Modificación Inicializador campos F2_TPDOC y F1_TIPNOTA BOL

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _