FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA447 - Pedimentos - F9 en NFE de extracción vinculada a pedido Mensaje: En la orden de compra, solo hay 0, cambie la orden de compra o la cantidad

Ocurrencia
En el módulo de Compras (SIGACOM) al incluir un Pedimento (MATA447) con extracción de Orden de compras a través de la función <F9>, se presenta el mensaje de validación:

En la orden de compra, solo hay 0, cambie la orden de compra o la cantidad




Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12


Causa
Se ha identificado que a nivel base de datos que existe el campo Ctd.a Clasif (C7_QTDACLA), el cual es actualizado por los pedimentos (MATA447) para determinar el saldo disponible de productos en una Orden de Compra, siendo que el campo Ctd. Entrega (C7_QUJE) es el que en la versión 12.1.27 esta llevando el control de lo recepcionado por una Remisión o una Factura de Entrada basado en Pedido de Compra.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:


1. Garantice tener las siguientes rutinas con fechas igual o superior a las indicadas; En caso de tener una fecha desactualizada, deberá solicitar la actualización correspondiente a soporte Protheus Mercado Internacional vía ticket;

  • MATA447 al 11/11/2020 (DMINA-10218)

  • MATA447B al 06/04/2020 (DMINA-8604)

 


2. Aplique la actualización en su ambiente de pruebas inicialmente, con previo respaldo del su RPO;


3. Realice la validación del registro del pedimento con un nuevo pedido de compra.

  • 8391499_DMINA-8604_DT_Actualizar_C7_QTDACLA_en_la_Generación_de_Dctos_Pedimentos_MEX

  • En la rutina Generación de Facturas en Compras y Movimientos a Almacén (MATA447B) se crea la función ActSaldoOC() para actualizar el Saldo del Pedido de Compra con respecto al pedimento generado y en la generación de documentos del pedimento.

    En la rutina Pedimentos (MATA447) en la función MT447Altas() y MT447Bajas() se agregan las validaciones para actualizar el campo Ctd.a Clasif (C7_QTDACLA) solo si la factura se registra en ese momento y asociando a una Pedido de Compra, también se realizan ajustes a la funcionalidad de la selección de partidas de la Orden de Compra en las funciones MT447DEL2() y MT447OC2() y se agrega la validación del campo Cantidad en la función MT447LOk2().

    En la rutina Validación de Documento de Entrada (MATA103X) en la funciones A103ItDev() y A103Item() se agrega validación para no entrar en funciones que superponen la cantidad y el valor del pedido sobre la factura.

     

 

Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:

MP - COM - MATA447 - Pedimentos - Documentación

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _