Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Stock y Costos (SIGAEST) - MATA340 Error.log: Update error - lock required - File: SD3

Ocurrencia
En módulo Stock y Costos, al ejecutar la rutina de Ajuste de Inventario (MATA340) se presenta error.log:

Update error - lock required - File: SD3010 in file D:\bamboo-agent-5.7.2\xml-data\build-dir\TP11-TECX17V3-TECXWIN64\advpl\advplfile.cpp at line 77 on A340INVENT(MATA340.PRX)

mceclip0.png

Ambiente
Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Stock y Costos (SIGAEST) – A partir de versión 12

Causa
Este incidente ocurre por inconsistencias a nivel código en el procesamiento de inventarios con el parámetro MV_TTS=N, impidiendo concluir el proceso.

Solución

1. Verifique que la fecha de la rutina MATA340 se encuentre con fecha igual o superior al 16/04/2020.

2. En caso de tener la rutina desactualizada, deberá solicitar el paquete de actualización al equipo de soporte Mercado Internacional.

3. Antes de aplicar el paquete de actualización (patch) deberá realizar un respaldo de su RPO.

4. Aplicar el paquete de actualización (patch),

5. Validar la ejecución de la rutina, y confirmar que el error.log es corregido.

 

Conozca más:

TDN - DMANMAT01-27078 DT Sistema gera inconsistência Update error - lock required - File: SD3 no processamento de inventario.

Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
MP - CFG - Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _