Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - Remito de Entrada con descuentos el cálculo de valores decimales no coincide con el cálculo

Ocurrencia
En módulo de Compras, se identifican inconsistencias en los valores de descuentos de un Remito de Entrada, ya que el cálculo de valores decimales difiere del cálculo correspondiente.


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12

Causa
Este incidente ocurre por configuración incorrecta de los Disparadores D1_DESC y D2_DESC en diccionario de datos del ambiente:

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Realizar respaldo de la tabla de disparadores de su ambiente (SX7)
2. Ingresar al módulo Configurador, en el apartado Base de datos>Diccionario>Disparadores

- Localizar disparador D1_DESC de la secuencia 001, confirmar la configuración de la regla conforme a lo siguiente:

mceclip0.png

En caso de tener un valor diferente, realice la adecuación por:

M->D1_VALDESC := Round(M->D1_TOTAL*M->D1_DESC/100,TamSx3("D1_VALDESC")[2])

- Localizar el disparador D2_DESC de la secuencia 001, confirmar la configuración de la regla conforme a lo siguiente:

mceclip1.png

En caso de tener un valor diferente, realice la adecuación por:

M->D2_DESCON := Round(M->D2_TOTAL*M->D2_DESC/100,TamSx3("D2_DESCON")[2])


3. Luego de verificar y grabar las adecuaciones al diccionario de datos, ingresar al módulo de Compras y realizar la carga de un Remito de Entrada con Descuentos y verificar que el redondeo de decimales se efectúa de forma satisfactoria.

 

Conozca más

TDN - DMICNS-9279 DT Error en Remito de entrada con descuentos ARG

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _