Ocurrencia
Error en la contabilización de asientos contables On-Line y Off-Line, manuales o de integración con otros módulos: argument #0 error, expected C->N, function val on DETPROVA(MATXFUNA.PRX)
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) – A partir de versión 11.80
Causa
Este incidente ocurre debido a inconsistencias en la configuración del asiento estándar, a través de la rutina CTBA080-Asientos Estándar (Tabla CT5), la cual es validada a través de la función de sistema DETPROVA, y específicamente porque alguna variable está recibiendo un tipo de valor diferente al esperado.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. En el error.log localice la variable cPadrao en la función DETPROVA, para identificar el asiento estándar que está generando el error.
2. Después busque el código del asiento estándar en la tabla CT5 dentro del error.log, para identificar la secuencia del asiento estándar a revisar. Localice que el tipo de valor de sus configuraciones coincida con el tipo de valor de los campos de la CT5.
3. Localice que el valor que está recibiendo la variable de dicho campo.
En este caso el campo CT5_RECORI, el cual es de tipo carácter, está recibiendo un valor de tipo numérico acorde a la variable Local 71: NRECORIGEM(N) :0, lo anterior es lo que está generando inconsistencias.
4. Luego de localizar la inconsistencia ingresar a la rutina de asientos estándar (CTBA080) para realizar los ajustes del asiento correspondiente.
En el caso de la inconsistencia de la función RECNO
- Si el campo es de tipo carácter configure: AllTrim(Str(SE2->(RECNO())))
- Si el campo es de tipo numérico configure: SE2->(RECNO())
Conozca más
MP - ADVPL - ¿Cuál es el uso de la función RECNO() de AVDPL?
Nota:
- Los campos configurados en el asiento estándar deben existir en el sistema.
- Garantizar que la sintaxis en ADVPL utilizada en la configuración sea la correcta.
- El análisis, debug y ajuste a funciones de usuario asignada en el asiento estándar, exceden el alcance del soporte al producto estándar.
0 Comentarios