Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) - MNTA180 - InterFunctionCall: cannot find function MNTA120TAR in AppMap on { || (MNTA120Tar( M->TP5_TAREFA, 'TP5' ))

Ocurrencia
En módulo Mantenimiento de Activos(SIGAMNT) al intentar incluir una Tarea en la rutina MNTA180 Mantenimiento Estándar, se genera error.log:

InterFunctionCall: cannot find function MNTA120TAR in AppMap on { || (MNTA120Tar( M->TP5_TAREFA, 'TP5' )) .and. (.t.) .and. (NGFOLDTAR('A','P'))}(MSGETDAD.PRW)

mceclip0.png

 


Ambiente
TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) – A partir de versión 12.1.17

Causa

El incidente ocurre puede ocurrir por alguna actualización aislada de las rutinas del módulo de Mantenimiento de Activos, en este caso la rutina MNTA120 a partir de la fecha 01/07/2019 hace llamada a la función "MNTA120TAR" la cual se encuentra compilada en la rutina MNTA120 , si la rutina se encuentra desactualizada, será generado el error.


Solución

Para solucionar esta ocurrencia, deberá garantizar que la fecha de la rutina MNTA120 sea igual o superior al 01/07/2019, realice los siguientes pasos:

1.- Garantizar tener la rutina MNTA120 con fecha mayor o igual al 01/07/2019.

2.- En caso de que tenga fecha menor a esta, solicite a soporte técnico la actualización de la rutina vía ticket.

3.- Aplicar las actualizaciones correspondiente, en su ambiente de pruebas inicialmente, con previo respaldo del RPO y eligiendo la opción "Aplicar solo fuentes actualizados".

4.- Confirmar que el error.log no es presentado luego de la actualización.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _