Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBA190-ORA-12899: value too large for column "MP2210COL"."CVX010"."CVX_NIV05" (actual: 20, maximum: 16)



time.png Tiempo aproximado para lectura: 00:05:00 min

Ocurrencia
En el módulo de Contabilidad de Gestión (SIGACTB) al ejecutar el reprocesamiento a través de la rutina CTBA190, se presenta el siguiente error log:

Error : 12899 - ORA-12899: value too large for column "MP2210COL"."CVX010"."CVX_NIV05" (actual: 20, maximum: 16)

ORA-06512: at "MP2210COL.CTB204_01_01", line 64

ORA-06512: at "MP2210COL.CTB210_01_01", line 62

ORA-06512: at "MP2210COL.CTB220_01_01", line 232

ORA-06512: at "MP2210COL.CTB020_01_01", line 124

ORA-06512: at line 1

 ( From tOracleStmt::SPExec )

Thread ID [26372] User [Administrador] IO [2552] Tables [66] MaxTables [67] Comment [CTBA190 - TCPIP - ThreadID(11336)] SP [CTB020_01_01] Traced [No] SQLReplay [No] InTran [No] DBEnv [ORACLE/MP2210COL] DBThread [,)] Started [30/05/2023 14:13:54] IP [172.31.64.1:2210] IDLE [ ] InTransact [ ] Memory [0] Running [ROP_SPEXEC for 0 s.] RCV [68916] SND [192153] TCBuild [20220303-20230224] TCVersion [22.1.1.2] ARCH [64] OS [WINDOWS] BUILD [RELEASE]

CTB020_01_01






Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - a partir de la versión 12.1.33

Causa
Este error ocurre por inconsistencias en tamaño de los campos.

Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:

  1. Ingrese a APSDU, realice un respaldo de sus tablas SX2, SX3, SXG y CT2 (completas)
  2. Respalde su RPO
  3. Aplique las últimas actualizaciones de expedición continua.

    12.1.33
    https://suporte.totvs.com/portal/p/10098/download?e=1039084

    12.1.2210
    https://suporte.totvs.com/portal/p/10098/download?e=1080337

  4. Ingrese al Configurador (SIGACFG)\Base de datos\Diccionario\Store Procedure), desinstale los Stored Procedure







  5. En el módulo Configurador\Base de datos\Diccionario\Base de datos, verifique que
    el tamaño del Grupo de campos “040 - Entidad Contable 05”, se encuentre con un
    tamaño igual a “20”, caso contrario ajuste el tamaño ejemplo:








  6. Ingrese a APSDU y abra la tabla SX3, filtre por los campos CT2_EC05DB y
    CT2_EC05CR



    Modifique la columna X3_GRPSXG de los 2 campos, quitando el valor “003” y
    colocando el valor “040”



  7.  En el módulo Configurador\Base de datos\Diccionario\Base de datos) el tamaño
    de los grupos de campos
    “004 - Centro de Costo”,
    “005 - Item Contable” y
    “006 - Clase Valor”.
    Por estándar están con tamaño “9”



    Ajuste el tamaño de los grupos de campos “004 - Centro de Costo”, “005 - Item
    Contable” y “006 - Clase Valor” a “20” para homologarse con el grupo de campos
    “040 - Entidad Contable 05”



  8.  Guarde los cambios realizados en su diccionario de datos

  9. En el Configurador (SIGACFG)\Base de datos\Diccionario\Store Procedure), instale
    nuevamente los store procedure

    Nota: Es importante que cuente con las últimas actualizaciones disponibles de los
    store procedure y rutinas involucradas, por lo que deberá aplicar el último patch de
    expedición continúa disponible en el portal









  10. Ejecute el Reprocesamiento Contable y valide que finalice de manera exitosa

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _