Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - GPEA010-Error log array out of bounds ( 0 of 5 ) on GP310SXB(GPEA310.PRW) al seleccionar un elemento de la consulta (F3) del campo RA_SUBCOT



time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia
En el modulo de Gestión de Personal (SIGAGPE), al seleccionar un elemento de la consulta (F3) del campo Sub. Cotiz. (RA_SUBCOT) en la inclusión o modificación del empleado en la rutina GPEA010 para ambiente de localización país Colombia, se genera un error.log:

THREAD ERROR ([4772], magdalena.lopez, JSVYK132021) 21/04/2023 08:33:43
array out of bounds ( 0 of 5 ) on GP310SXB(GPEA310.PRW) 09/11/2022 15:01:35 line : 2307



Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - a partir de la versión 12.1.33

Causa


Este error ocurre por inconsistencias en la configuración de la consulta estándar (F3) del campo RA_SUBCOT, ejemplo:



Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:

1. Realice un respaldo de su tabla SXB.

2. Garantice tener la consulta S24COL correctamente configurada en la tabla SXB, de acuerdo al boletín técnico de la localización Colombia:

DT Localización Colombia (SIGAGPE) - Protheus 12

Preste atención a la validación del campo 
XB_CONTEM debe tener la siguiente información  GP310SXB("S024","CODIGO")



3. Una vez la consulta S24COL este configurada acorde a la configuración indicada en el boletín, valide que al capturar el campo Sub. Cotiz. (RA_SUBCOT) el error log ya no se presente.


En adjunto se encuentra un video de ejemplo en donde una vez se corrige la consulta S24COL , el error log ya no se presenta.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _