Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI – Compras (SIGACOM) – MATA121 Help: A120RSPED Problema: Usuario sin permiso para dar mantenimiento a este pedido. Apenas el usuario que agregó este pedido puede darle mantenimiento

time.png Tiempo aproximado para lectura: 00:05:00 min

Ocurrencia

En módulo de Compras, al cambiar la orden de compra envía mensaje Help: A120RSPED Problema: Usuario sin permiso para dar mantenimiento a este pedido.

Ambiente

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Compras (SIGACOM) – Reléase 12

Causa

Este incidente se puede presentar por información de los campos C7_GRUPCOM / C1_GRUPCOM

Solución

Revise las siguientes consideraciones

Consideraciones:

  • Por Estándar del sistema, realiza la siguiente comprobación cuando el parámetro MV_RESTPED está configurado con “S”

|_Si el campo está informado, comprobar que el usuario actual pertenece al grupo de compras

    C7_GRUPCOM / C1_GRUPCOM;

||_Si el usuario pertenece al grupo de compras, permitirá la modificación

||_Si no pertenece devuelve el mensaje de ayuda"A120RSPED"

|

|_Si el campo no está informado, compruebe si el usuario actual es el mismo que en el campo

    C7_USER / C1_USER;

|_Si es el mismo usuario, permite la modificación.

|_Si no es el mismo usuario devuelve el mensaje ayuda "A120RSPED"

 

Con base a las validaciones anteriores, a continuación, se presenta una sugerencia que puede realizar para que su usuario en cuestión también pueda cambiar la orden de compra:

  1. A través de Consulta genérica, abra la tabla SC7 / SC1 y localice la orden de compra / SC a la que el usuario no tiene acceso;
  2. Verifique el valor del campo C7_GRUPCOM / C1_GRUPCOM;
  3. Ingrese al módulo de compras rutina actualizaciones>Adm.Compras>Compradores y registre al usuario deseado como comprador;
  4. Ingrese a la rutina Actualizaciones>Adm.Compras>Grupo de Compras, y con el valor previamente encontrado en el campo C7_GRUPCOM / C1_GRUPCOM ubicar el grupo de compras y modificarlo, incluyendo el comprador previamente registrado. De esta forma, el usuario podrá cambiar las órdenes de compra / SC incluidas por los usuarios de este grupo de compra.

Observaciones:

  • El campo C7_GRUPCOM sólo se registra cuando se utiliza la configuración completa para el control de autoridad, utilizando grupos de solicitantes vinculados a grupos de compra;

  • Para que el campo C7_GRUPCOM quede registrado, el proceso debe seguir exactamente esta ruta: Inclusión de SC (por un solicitante registrado) |--> Generación de Cotización |--> Análisis de Cotización |--> Generación de PC;

  • En este proceso se registrarán los campos: C1_GRUPCOM, C8_GRUPCOM y C7_GRUPCOM;

  • Si el proceso utilizado es diferente a las validaciones, la posibilidad sería mediante el uso de un punto de entrada al registro C7_GRUPCOM.

A continuación, se proporcionan los puntos de entrada que puede utilizar en caso de requerir. 

MT120APV - http://tdn.totvs.com/pages/viewpage.action?pageId=6085466
MTA120G1 - http://tdn.totvs.com/pages/viewpage.action?pageId=6085571
MTA120G2 - http://tdn.totvs.com/pages/releaseview.action?pageId=6085572
MTA102G3 - http://tdn.totvs.com/pages/releaseview.action?pageId=6085573

  • Si el campo C7_GRUPCOM está en blanco, la única forma de que otros usuarios tengan acceso a las órdenes de compra será desactivando el parámetro MV_RESTPED=N
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _