Tiempo aproximado de lectura: 00:05:00 min
Ocurrencia
Al intentar abrir una rutina del menú surge el error: "No se pudo aplicar el filtro relacional"
Ambiente
Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Configurador (SIGACFG) - Todas las versiones 12
Causa
El mensaje presentado es una protección creada para los filtros relacionales que encuentran algún problema a aplicar, como la ausencia de una relación en SX9 o el no uso de la tabla en el menú donde se agregó la rutina (tablas seleccionadas al colocar la rutina en el menú).

Solución
La tabla SX9 es responsable de las relaciones de las tablas en Protheus, en ella son las tablas que se relacionan y el campo que realiza esa relación.
Las tablas de rutina en el menú se seleccionan en el momento del registro de rutina, debajo de la pantalla del configurador donde se realiza la selección:
Antes de esta protección, podían aparecer datos que no debían presentarse en la navegación, debido a la no aplicación de un filtro que se iba a aplicar. Cuando se presenta este mensaje, debe verificar exactamente la información ya mencionada: si existe una relación entre las tablas presentadas en el mensaje o si las tablas presentadas se agregan en el menú de rutina, a través del Configurador.
Si una de las opciones no existe, realice la adición y vuelva a probarla. Si todo es correcto, póngase en contacto con el equipo de soporte de TOTVS para el análisis.

0 Comentarios