Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - GPER884-El resultado de la digestión debe ser igual al resultado de la desencripción del sello. Cadena Origial



time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia
En el módulo de Gestión de Personal al intentar timbrar un recibo de nómina a través de la rutina GPER884 se genera el siguiente error:

Error

El resultado de la digestión debe ser igual al resultado de la desencripción del sello. 

Cadena Origial:||4.0|0000040101|000010120220201|2022-11-29T19:17:32|30001000000400002443|7894.75|776.76|MXN|7117.99|N|01|PUE|11529|XIA190128J61|TOTVS MEXICO SA DE CV|601|TUCA5703119R5|IRAM MENDOZA MARTINEZ||605|CN01|84111505|1|ACT|Pago de n��mina|7894.75|7894.75|776.76|01|1.2|O|2022-02-15|2022-02-01|2022-02-15|15|7894.74|776.76|0.01|Y6757556576|XIA190128J61||12345678903|2022-01-03|P6W||No|01|02|000004||ANALISTA NIVEL 1|1|04|||7894.74|0.00|CMX|7894.74|7894.74|0.00|001|100|Sueldo|7894.74|0.00|776.76|002|403|ISR Neto|776.76|002|404|Subsidio para el empleo (Efectivamente entregado al trabajador).|0.01|0.01||




Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - todas las versiones.

Causa

El error "El resultado de la digestión debe ser igual al resultado de la desencripción del sello" se presenta por las siguientes inconsistencias:

1.- Ausencia de atributos obligatorios.

2.- Uso de caracteres especiales sin tratamiento.

3.- Espacios dobles o adicionales.

4.- Datos existentes en el nodo pero no en la Cadena Original o viceversa.

Ejemplo
:

En el siguiente ejemplo podemos observar que el atributo Nombre tiene un espacio doble entre el nombre y el apellido.

Los atributos DomicilioFiscalReceptor, TipoContrato y Departamento se encuentran vaciós.


mceclip0.png

Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:
1. Ingrese al maestro de empleados GPEA010;
2. Localice el empleado que presenta las inconsistencias en el XML;
3. De acuerdo al ejemplo proporcionado arriba para solucionar el doble espacio en el nombre del empleado, elimine un espacio del campo RA_NOME.

Antes

mceclip1.png

 

Elimine un espacio:

mceclip2.png

4. Para los atributos que se encentran vacíos, localice los campos en el maestro de empleados y realice la captura, siguiendo con el ejemplo anterior:

Los campos a llenar son los siguientes:

Atributo DomicilioFiscalReceptor = RA_CEP

mceclip3.png

Atributo TipoContrato=RA_TIPCON

Atributo Departamento=RA_DEPTO

mceclip4.png


5. Una vez capture y modifique los campos, valide que el XML se genere correctamente y el error ya no se presente:

mceclip5.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _