Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

FRAMEWORK - Framework (Línea Protheus) MI - Archivo PDF se genera con tamaño muy pesado cuando tiene imágenes (TotvsPrinter)

FRAMEWORK - Framework (Línea Protheus) MI - Archivo PDF se genera con tamaño muy pesado cuando tiene imágenes (TotvsPrinter)

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
En Protheus, al incluir archivos de imagen PNG o JPG en el informe, la impresión genera un PDF con tamaño pesado, lo que origina problemas para adjuntar archivo.

Ambiente
FRAMEWORK - Framework (Línea Protheus) MI - Versión 12

Causa

El incidente ocurre, por el tratamiento de manejo de archivos .JPG y PNG, que incluye la impresora "Microsoft Print to PDF"


Solución
Para solucionar esta ocurrencia, se realiza tratamiento para los archivos JPG para la clase utilizada para leer y agregar la imagen al PDF a QImageReader que es capaz de mantener la compresión de este tipo de archivo.

La corrección, se realiza en el archivo TotvsPrinter a partir del Build 2.1.5.

En tanto para solucionar el incidente, deberá realizar la actualización del archivo dentro de la carpeta de su "smartclient" para la versión 2.1.5 o superior.

 

Conozca más

TDN - Correção - PDF com tamanho elevado ao adicionar imagens no relatório

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _